Monday, February 9, 2009

Windows 7. Media Centre. Some Issues.

So, I’ve been running Windows 7 for a while now. I must say that for the most part I am very happy with it.

Now to the issues. Please remember, I only use this as a HTPC, so I am running the Media Centre component exclusively.

I live on the Gold Coast, in Queensland, Australia. I can receive signals from the Metro Brisbane broadcast tower, also the Regional Gold Coast tower and when the moons are phased correctly the Regional Currumbin broadcasts.

I only use Digital DVB-T, no UHF analogue broadcasts.

  • Microsoft. I have a Hauppauge HVR-2200 DVB-T PCI-Express adapter. Why can’t I use the FM radio. I know it’s analogue and I tune into digital TV. The card supports it, why can’t you? Why should my chosen TV format affect my use of radio broadcasts? Hell, even better, if my card supports FM radio, but I select to use digital TV, remove the damn FM radio option so it doesn’t taunt me.
  • I cannot get a scheduled recording to work consistently. The OS chooses to provide me with troublingly erroneous errors or simply no data at all. My wife likes to watch Bold and the Beautiful, which screens on Channel 10. I configure a scheduled recording for the series, specifically set to only record on my chosen Channel 10 broadcast and ignore any other Channel 10 broadcasts. Sometimes it records it, mostly it doesn’t. Sometimes it gives me an error in the Recorded TV history indicating a tuner conflict (which should not be the case) or it simply logs nothing and records nothing. Even the Event Log fails to explain the cause, it lacks any reports of the event whatsoever.
  • Erratic and unexplainable TV quality issues. My signal quality is excellent and is evidenced by the most of our TV viewing. Randomly channels will have major issues with video and audio stutters. Or I receive No Signal errors, I switch channels and it’s fine, I switch back and the channel works again. Sometimes nothing works, I shutdown Media Centre or have to resort to rebooting the whole system and everything starts working fine again. System isn’t short on memory, no excess CPU usage, just Media Centre freaks out and needs a good swift kick in the behind.
  • Movie playback. Supports MKV apparently. Just won’t show the files anywhere. Why must I hack the registry? Plays various codec's, but only if I use the right container format for the movie. Plays back AC3 and DTS, but not in my AVI or MKV files. Plays AAC audio, but only in some containers and not others. Skips and fast forwards/rewinds in some files, not in others, even files with same container and codec mix.
  • Music randomly shows Cover Art. I have everything in the same folder structure, with folder.jpg cover art images, works with 298 albums, but not all 514 albums. Sometimes even randomly switches which album art it will show.
  • If I set a folder for use with Movies, why does content from that folder show up in another category. If they all link up, why must I configure each category separately. e.g.. Pictures shows all my album art, whilst Music cannot???? That album art should not show in Pictures ever, as I only have that directory configured for Music.

Probably enough ranting for now, on to submitting my feedback officially and working through the bugs to get it working how I want.

Hey, it’s a Beta. But my family just wants something that works. maybe I should just install Vista, but….

Sunday, January 25, 2009

Windows 7 Media Centre

I purchased the Hauppauge HVR 2200 for my system on Friday and the Hauppauge MCE Remote.

Installation was a breeze. Dual tuners are mucho awesome. This card comes highly recommended in all Media Centre circles and it very much deserves the praise.

Having the remote just makes life so much easier using Media Centre, plus my poor old Microsoft Wireless Keyboard and Mouse have piss poor radio range, so no more standing up and walking to the TV to do anything.

So far, I have to say my Windows 7, Media Centre and Hauppauge experiences thus far have been nothing short of excellent. If your in the market for a DVB-T tuner, I would highly advise at least looking at the Hauppauge range.

Finally found the Australian support site, so I have the latest drivers now and will probably install them tomorrow morning. Just for the hell of it as it isn’t broken, but I’m running Windows 7 so may as well stay on the bleeding edge all the way.

Incidentally. DVico cards aren’t quite as bad as I’ve read about, but their drivers are complete rubbish. Was previously using the DVico FusionHDTV Plus card, although it worked well, it did experience the occasional glitch. Using latest release from website and previously the Microsoft provided drivers from Windows Update.

Wednesday, January 21, 2009

Windows 7 Installation

I said I would post about the installation.

Firstly, SIS chipsets suck. I have always disliked them and my experiences continue to remain consistent with every new generation.

After first boot, Ethernet, RAID and DVB-T were not detected. Inserted my flash drive to install drivers and although USB hardware was detected it did not work correctly. Realised I had installed a USB Mass Storage Volume and then puked.

Installed LAN drivers from SIS site, after burning them to CD.

Now I have internet and Windows Update happily installed drivers and updates for everything. Yay, USB now works for Mass Storage devices. Even installed drivers for my crappy Dvico Fusion DVB-T adapter.

Once that was out of the way everything worked smoothly. Installed Microsoft's Windows 7 beta drivers for my keyboard and mouse. Installed Promise FastTrack drivers for my RAID setup and I’m happy as a pig in shit.

Installed the Kaspersky 8 beta for Windows 7. I had to update databases several times and reboot countless times, but it finally stopped bitching that it needed to be updated. Now I am going to turn of the oh so very annoying firewall. When will security vendors realise I and people like me understand the pop ups, but the average user has no idea what they mean. Plus, add rules for basic Windows services that run on 127.x would you please. 36 pop ups on first boot after install and I didn’t even have the PC online.Geez…

Anyway. Connecting to the TV in lounge tonight. Have yet to even load Media Centre, so keen to see what the new interface and options are like.

Media Centre

Today is the day.

Will be commandeering the TV from the family this evening and setting up Media Centre for Windows 7. Looking forward to finally testing it out.

As far as Windows 7 goes, all good, nothing bad to report thus far. Although the Kaspersky Windows 7 beta leaves much to be desired.

Monday, January 19, 2009

Windows 7 Beta

Finally sorted all the issues with the SIS motherboard. I hope, touch wood…

Currently undergoing the initial installation. I have hopes this will become my first Media Centre.

Once I get it all up and running I’ll report on my experiences.

Silicon Integrated Systems Corp


They have been around for years now. I appeal to you, name one chipset they have developed that isn’t a complete waste of silicon.

Please. Seriously. Cause I truly want to know.

From the desk of someone who keeps running into the crap they make and really wishes it would just stop.

Friday, December 19, 2008

post 0. or, the beginning.

Lost count of how many times this has existed and been deleted by me, ah well, least I’m consistent.

Just a place holder really.

I will get around to filling this space when I find a purpose for it.